JeffRay
Posts: 1131
Joined: Thu Dec 11, 2014 9:12 am

Re: Charging speed only charges at 3.9kw

Tue Oct 20, 2020 3:15 pm

ASM,

The dealer needs to run their standard battery diagnostics plus check the charging rates so plan to bring the car in half charged. This will check the battery and the actual charging rates.

For me, the software gliche was switching to a lower charging rate automatically for some unknown reason. The service advisor said I had switched it on the dash. I replied that I had no idea where the menu was so I did NOT down throttle the setting.

Separately, I had seen a post where the charging apparatus on the car was compromised. Also, we have seen some rare cases that the inverter, etc was damaged by leaking coolant.

These are all things that MB is aware of, even if your local MB shop had not.
Jeff in NYC
MB '21 GLC300; MB '06 E500W; MB '81 380SL
Retired: MB '17 B250e; MB '14 Be

Asm123
Posts: 6
Joined: Fri Oct 16, 2020 2:08 am

Re: Charging speed only charges at 3.9kw

Wed Oct 21, 2020 6:47 pm

Hi JeffRay

Many thanks for your advice, really appreciate it at least i can tell them where they need to look, I'm sure they won't have as much knowledge as you.

Its booked for next Tuesday and I shall definitely report back on this forum (I prey with good results).

Once again thank you soo much for taking the time to help me.

hfeb
Posts: 8
Joined: Thu Sep 05, 2019 9:00 am

Re: Charging speed only charges at 3.9kw

Wed Nov 04, 2020 2:05 pm

my guess is that it could be that your charger is 1 phase 32 amps. The car charges with 3 phases at 16 amps each, and this gives around 10kW. If you only have one phase it will charge at 1/3 of that.

mercevdriver
Posts: 4
Joined: Tue Nov 09, 2021 2:11 pm

Re: Charging speed only charges at 3.9kw

Wed Nov 10, 2021 4:58 am

Yes, i have the same issue, how did you get on at the dealership. ;)

diggerdave
Posts: 7
Joined: Sat Jul 09, 2016 7:28 pm
Location: Seattle

Re: Charging speed only charges at 3.9kw

Sun Nov 14, 2021 3:31 pm

I have a similar charging issue. I'm in the US, we don't have 3phase in our homes. I do have Level 2 capable EVSE served by a 30amp circuit. With my old Juicebox 60amp EVSE I used to charge at about a 26amp rate. It shorted out and I recently replaced it with a 40amp Wallbox. And have been charging both my 2014 Bclass and my 2017 Chevy Bolt at 23amps. The Wallbox is new and strange to me and it's still a hassle to get it to start the current flow sometimes. Now the Bclass is throwing a Malfunction Error take in for Service. I can get around that and get the charging to start by turning down the Wallbox EVSE from 23 amps to 19. I haven't had any problem with the Bolt. I am wondering now if the the charger on the Benz is damaged? Anyway to tell? Will an OBD device give more info, error description etc?

tia,
dave

laurentm
Posts: 3
Joined: Tue Nov 02, 2021 2:18 am

Re: Charging speed only charges at 3.9kw

Wed Nov 24, 2021 5:52 am

In Europe, the B Class will charge @16A x 1 phase (with 230 Volts AC Mains) or 16A x 3 phase (400 Volts between live wires ) which means 3680 W or 11040 W, but not at all 7,2 Kw.

According to the stickirt on the charger socket door, the car can accomodate from 100 to 400 Volts.
In 110 Volts, this means probably 22h on a 20 Amps socket for a full charge.

Return to “Technical Discussions”