Zubair
Posts: 4
Joined: Thu May 06, 2021 4:38 am

B250e shaking in drive

Fri Apr 15, 2022 10:13 am

After one and half years of ownership, my car broke down. The car starts shaking when accelerating then grinds to a halt. I have left it for inspection with the local Mercedes dealer, but still waiting to hear what the issue is. Anyone have any ideas?

snowds
Posts: 45
Joined: Thu Sep 11, 2014 6:16 pm
Location: Atlanta GA

Re: B250e shaking in drive

Sat May 28, 2022 8:47 am

Any progress on this? I'm guessing you need a new motor. Mine was doing the same thing, and is now in shop. They are saying new drive unit at a cost of $21k.

Envador
Posts: 4
Joined: Mon Jul 05, 2021 6:55 pm

Re: B250e shaking in drive

Wed Sep 07, 2022 6:47 pm

My B250e has a shaking issue!
It started yesterday and today still persists.
Not sure if it matters, but I'll describe the drive session that lead up to it:

Yesterday
1. I drove to the library to pick up my daughter - about a 15 minute drive on local streets with 10 or less traffic lights. I pulled into the library and parked.
2. I was parked for about 10 minutes. During this time, the car was in P. AC was set at 72F auto. Outside temperature was about 94 degrees, so the AC was blowing pretty hard.
3. My daughter came out of the library, got into the car. I shifted the car into R, backed out of my spot. I didn't notice anything strange at this time.
4. Then I shifted into D to proceed and the car started lurching, shuddering, stop-and-go. The feeling was like someone learning to drive a stick shift for the first time, or a gas car trying to drive from a standstill starting in 2nd gear.
5. I pressed the brakes and stopped the car and shifted back to P.
6. Shifted back into D to try again, and at this time, I looked at the screen and noticed that it was in D, and not the usual D-auto.
7. I played with the minus/plus paddles, saw the D change from D-, to D, to D+, but didn't offer D-auto. I thought that was weird. Turned off AC for the rest of the drive home.
8. Back on D, the car shuddered and lurched trying to "get going" but it did after a a second of stuttering.
9. When in motion, there was no shuddering or stuttering when pressing the accelerator.
10. I reached a stop sign about 1 block away. From this full stop to get going, the shuddering was only very brief.
11. Reached a red light about 3 blocks away. From this full stop to get going, there was no more shuddering.
12. Had to stop by Taco Bell on the way home to pick up an order that was already paid for (even though by now I just wanted to get home).
13. Made it through the drive thru line without incident.
14. Made it home without incident.

That was yesterday.

This morning:
1. Plugged it in to charge from 1/2 full to full charge. Took about 4 hours on our 16A charger.
2. Unplugged it, and left it in the driveway for about 5 hours.
3. Tried driving it: Shifted to D (did not need to R out of driveway since I back in) and it shuddered badly for about 20 feet but got going.
4. Drove it to the park about 5 blocks away. I reached a top speed of about 48 mph. No shuddering.
5. Set the car in P for 1 minute. Then shifted back to D to drive home. I didn't use R this whole trip yet.
6. Shifted to R to back into drive way. Serious shuddering! Couldn't even make it up the driveway. I considered gunning it to see if it would decide to move, but didn't want to risk it.
7. Shifted to D, drove it around the block.
8. Drove up to the driveway and didn't try R again.

What next?
The next thing I want to try is check the 12V battery. Maybe it's just a low 12V after sitting in P in 94 degree heat with the AC blasting, maybe my 12V is just due to be replaced. I read elsewhere on forums that the dealer wants $650 to replace a 12V. Seems kind of steep!

If anyone has any suggestions or prior experience, please post. Thanks!

Envador
Posts: 4
Joined: Mon Jul 05, 2021 6:55 pm

Re: B250e shaking in drive

Mon Sep 12, 2022 7:32 pm

As a followup for anyone else that ends up here from googling, my stuttering/shaking problem is related to leaking seals and fluid getting into the motor and will need a rebuild. I just dropped it off at QC Charge in Vista, CA today. Wait times are currently 4 weeks to start work. I will keep this thread updated. I was quoted $4500 for a rebuild. I see others getting quoted $4000 and $4250, but I guess I'm a little late to the pity party and since the wait time is so long and dealerships are charging many times more, price inflation is understandable. Doesn't mean I wouldn't love to pay less, but I understand why.

Return to “Technical Discussions”