Won't go in Gear

B-Class Electric Drive Forum

Help Support B-Class Electric Drive Forum:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.


New member
Dec 10, 2020
Hello from Florida! We've bought this B class in Maine in 2015 and brought it with us to Florida. There aren't many of these in the states so Mercedes hasn't been any help with it, as they don't understand it. We've had this serious problem starting last year where once driven somewhere, when you get back in to go home for example, the car won't go into drive or reverse. It will go into neutral with a little jiggering of the key. It keeps sending the error that you must push brake to put in drive etc..but of course the foot is firmly on the brake. We've taken it to Mercedes twice, they've been no help, event said replace th motor..then the problem will go way and we'll drive it for a while until the problem arises again. I can email videos of what the dash controls say. Has anyone had this problem? It's really frustrating as we are ghost busting and Mercedes just shrugged their shoulders and charges us $400 to look it over. One mechanic that knows electric cars said he thought it might be a solenoid in the shifter, told that to Merceds, again no help. Really feel left out in the cold here with an orphan that Mercedes doesn't seem to car about servicing. Has anyone encountered this type of problem?
I have not heard of this problem. However, I must admit that frequently ours goes into neutral, but I believe its because I don't hit it up, or down long enough. Once in neutral, one more hit puts it in gear.

Have you noticed if it goes into reverse easier than drive? You have to go from Reverse to Drive, or vice versa?

Obviously your car isn't throwing a code, but this car is so different from a standard Benz. It could very well be a side effect of the 12v system as well. Lots of Gremlins in these cars. A really wonderful car when everything is working well(knocking on wood!). Good luck.

Sorry to hear about the issue. Having been a member of this forum for the last 6 years, I don't recall anyone reporting this issue. This compounds the usual lack of familiarity with our B250e by local MB dealers. I would recommend a couple of tactics that worked for other issues:

- Be pushy about the local dealer reaching out to MBUSA or MBgermany for assistance. They have to support MB products especially with the new electrics they are bringing to market worldwide. Talk to the top Service Manager, reach out to the top exec at the dealer.

- While this does not on its face sound like a B250e specific problem, the software could be tripped up by a battery or charging fault. This is a safety issue so talk about having to report this to FL DMV and US DOT/NHTSA

- Try another MB service department if current one fails you.

- Reach out to an independent electric car service company. I am blanking on the name but FL should have one as there are a lot of electrics given the climate.
LittleDunham said:

Did you ever get this resolved as this exact same problem has occurred on our 2015 B250E?

I think we have diagnosed the problem as a faulty battery heater.

SKU 242-500-07-00
I had the same kind of problem with my 2017 250. I push start button and all the lights on the dash lit up as usual but they didn’t go off as usual. So lights stayed on and the car wouldn’t go into d or r just n. I went through the process a couple more times and it worked. Now today after charging over night it turned on normally. I also have an ongoing issue with a noise but I don’t believe it’s related.
we are now having same problem.
Going to try and replace the 12v battery.
Hope this solves the problem.
I had the same issue and had to disconnect the 12v battery for 10 seconds to restart the system when this happened. learned to charge the 12 volt battery every other night to prevent the problem.
I had the same issue and had to disconnect the 12v battery for 10 seconds to restart the system when this happened. learned to charge the 12 volt battery every other night to prevent the problem.
Well my 12V was pretty dead, it turns out. I have a 12v charger and so charged it overnight. It worked. I drove it to Autozone and got a new battery. Now the car works better than before -- the red, serious warning light came off and alI I get now is the amber "malfunction" light, which I can cancel.

EDIT: I had to disconnect the battery to charge it using my charger. Charging it while connected did not clear the "not going into gear" error. Charging it while disconnected both cleared the error & charged the battery. Now I have a new battery, so all seems to work.